Domanda:
Sostituire l'applicazione Play Store Requisiti minimi di versione Android?
Jsncrdnl
2012-07-03 17:36:22 UTC
view on stackexchange narkive permalink

Possibile duplicato:
come faccio a dire ad Android Market che sto eseguendo una versione aggiornata di Android?

In effetti, ho installato una versione di Android superiore sul mio telefono (4.0 su uno ZTE Blade che normalmente supporta 2.1).

Ma quando mi connetto al mercato con il mio telefono, ho Sono ancora limitato a quella versione 2.1 e non riesco nemmeno a vedere le applicazioni della versione successiva mentre il mio telefono ora le supporta ...

Esiste un modo per ignorare tale limitazione della versione o almeno portarla alla 4.0 ??

Nota ::

MODIFICA ::

La limitazione che sto affrontando sembra legata a qualcos'altro oltre al mio firmware Android. In effetti posso scaricare quell'app: https://play.google.com/store/apps/details?id=com.anddoes.launc her&feature = sear‌ ch_result (anche se richiede il firmware 4.0).

Ma non riesco a scaricare questo: https://play.google.com/store/apps/details?id=AtomicTurtleStudio.DripLite&featu‌ re = search_result (mentre richiede firmware 2.2).

Domanda sciocca: sei sicuro che la tua rom sia una vera versione di ICS e non solo Eclair con la pelle per essere simile a ICS? usa 'adb shell getprop \ | grep -i version 'da verificare
Confermo che è la versione buona :: `[ro.build.version.release]: [4.0.4] [ro.build.version.sdk]: [15]`
Apparentemente c'è qc. sbagliato. Non vorrai fingere il tuo livello API. Domande diverse: hai ripristinato i dati delle app di sistema utilizzando TiBackup? Hai installato una versione Eclair obsoleta di GApps?
Non c'è niente di sbagliato, ho installato il GAPPS consigliato per la versione ICS .. Ho ripristinato alcune app con titaniumbackup ma dopo essermi connesso al market (il problema si era già verificato). Penso che debba essere collegato all'hardware del mio telefono che viene riconosciuto dal mercato di Google ...
Bene, non c'è niente di sbagliato con getprop ma con il mercato non corrispondente ad esso. forse solo un bug con la tua rom? Allora ho finito le idee ...
La mia ipotesi è che il mercato sia abbastanza intelligente da vedere il tuo hardware e stia basando i suoi filtri su quello piuttosto che sulla versione del sistema operativo che hai installato.
Sono abbastanza sicuro che questa domanda sia emersa prima, ma la mia ricerca-fu mi sta deludendo.
@AlEverett: Stavi pensando a questo? [Come faccio a dire ad Android Market che sto eseguendo una versione aggiornata di Android?] (Http://android.stackexchange.com/q/7238)
OP: la rom ICS per Blade è orribilmente rotta ed è sospesa ... http://www.modaco.com/topic/351670-ics-cm9-404-coldfusionx-for-the-zte-blade-rom-updated- 2806 / page__st__7520 # entry1980007
Puoi fornire un esempio di un'app che non puoi scaricare e il messaggio che viene mostrato?
@t0mm13b Non direi che è orribilmente rotto: lo sto usando come driver quotidiano.
Ecco un esempio di un'app che non posso scaricare perché il mercato sta considerando che il mio telefono è 2.1 mentre il requisito dell'app è 2.2 e la mia versione del telefono reale è 4.0 :: https://play.google.com/store/ app / dettagli? id = AtomicTurtleStudio.DripLite & feature = search_result
Ho testato un'altra app: `https: //play.google.com/store/apps/details? Id = com.anddoes.launcher & feature = search_result` e posso ottenerla mentre richiede il firmware 4.0. Sembra che la limitazione che sto affrontando sia legata a qualcos'altro oltre al firmware ... L'app che non è disponibile, nel mio caso, è `https://play.google.com/store/apps/details?id= AtomicTurtleStudio.DripLite & feature = search_result`
Una risposta:
R R
2012-07-04 21:00:19 UTC
view on stackexchange narkive permalink

Il problema qui non è nel software, ma nell'hardware. Il tuo telefono utilizza una CPU che non supporta il set di istruzioni ARMv7 che è richiesto da molti giochi in questi giorni.
È più che probabile che un recente aggiornamento per il gioco abbia interrotto il supporto per i set di istruzioni precedenti per migliorare le prestazioni o rendere l'app più piccoli.

Quindi non c'è altro modo che acquistare un nuovo telefono per supportare tali app?
Giusto. Il Blade era già obsoleto quando è uscito due anni fa.


Questa domanda e risposta è stata tradotta automaticamente dalla lingua inglese. Il contenuto originale è disponibile su stackexchange, che ringraziamo per la licenza cc by-sa 3.0 con cui è distribuito.
Loading...